Solution for Keyboard issue/problem – Apostrophe and Double Quote, Quotation marks, Tilde and Hat do not appear until another key is pressed on Windows 7

Very strange problem at a Sunshine Coast Business IT client where quotes and apostrophes would not display until the client pressed another key. Then this key and the quote or apostrophe would appear on the screen.

I did some further testing and the tilde ~ and the hat (is that what it is called?) ^ also didn’t appear when pressed until another key was pressed. The problem continues to appear even if another keyboard  is installed. So the setting had to be inside the Windows 7 Settings.

Checking in the keyboard settings it was apparent that the system was set to United States-International for it’s keyboard layout.  In Australia we use standard US keyboards so I changed it back to US and removed the United States-International keyboard just for good measure.

Windows 7 Keyboard Settings

After pressing OK, I tested it on a Word Document and the issue still remained. However after a reboot the system went back to normal and the client could use apostrophes and quotation marks mand get on with their job. I’m not sure why the system had changed to International keyboard layout- whether windows did it or the user did inadvertently I cannot be sure. It is an easy solution though thankfully.

Authored by Ian

Ian

Ian Johnson is a Director of OJ Networks. He has been working in IT since 1995. Mentored by the best, Ian started as Technical Support Officer for an innovative dialup ISP in Brisbane “Hub Communications”. He progressed to become a Web Design and Programmer in ASP, ASP.NET and PHP during his time at “The Lab Development Group” with David Vandenberg amonst others. Ian has been working as a Consultant on the Sunshine Coast since 2001 and became a Microsoft Certified Information Technology Professional (MCITP) Server Administrator in 2010 after which he formed OJ Networks. He has assisted numerous small businesses to reach their potential through IT Infrastructure Planning and Implementation and Web design, Development and Web Marketing. You can connect with Ian on Linked In.

Share This:
  • Brian

    Thanks Ian, this exact problem has been bugging me for months now! I changed to the standard US keyboard and removed the US Intl. from my list, as you suggested, and after a rebbot my “s, ‘s, ~s and ^s are now all working correctly again – perfect! :-)

  • Chris

    Thanks Ian. The same problem had been bugging me. When I started to implement your solution, I think I stumbled on the underlying problem: by default, Windows 7 uses ALT-SHIFT to toggle between available keyboard layouts. If the user has defined ALT-SHIFT as part of some other shortcut (eg in Word) it silently toggles the keyboard. So it is not necessary to remove the International Keyboard option: just disable the shortcut for keyboard switching, then pick the keyboard you want – and it will stick. Thanks again.

    • Kal

      Excellent..it worked..

    • You da real mvp!

    • Prathibha Nandini

      Thank you @Chris. ALT-SHIFT helped me!!

    • Adrian Gonzales

      THANK YOU ! Alt Shift solved everything :)

    • Yudhistira Eka Putra

      thanks mate, you saves me !!!

  • Phil

    I have tried this, however I still have ” instead of @ when I depress shift and the 2 key and £ instead of hash for the 3 key

    • admin

      Make sure you have your language AND your keyboard set to the correct region. Also check on the other tabs that you have the correct region set. It sounds like one of your settings is still wrong. If you are in the UK then make sure it is all set to “United Kingdom”.

    • Dash

      US and UK keyboards have those symbols switched on those keys. Go in to your keyboard settings as above and if you have the US keyboard switch to the UK one, and vice versa. I had this problem as I live in UK and set the computer to use UK english, but I bought my laptop in US, so it has a US keyboard layout.

  • It is called a caret, not a “hat”

  • Violet Ashes

    Thank you so much, I have been trying to fix this for months. Fortunately I didn’t need to reboot my system – glad the problem is solved! Thanks again.

  • mareeconway

    Let me add my thanks – I got a new computer, and this happened, finally annoyed me so much that I searched for a solution, and voila! All fixed :)

  • Pieter

    Thx! solved the problem without reboot on W7

  • Trevor

    The initial problem of the quote mark not appearing was a nuisance but not the end of the world. However when I wanted to type “o I was getting ö instead. After much searching I found this page. Thanks for the help!

    • melaniedrury

      I’ve had this too!

  • Singh Piara

    You need not Delete keyboard just change it to other drop down option. and don’t forget to restart. changes will only take place after restart. Thanks

  • Luka Perčič

    You should try Keyboarder when is ready (1month)
    http://www.getkeyboarder.com
    IT should make this kind of problems go away, or at least you can put the desired symbols in another space.

  • Baskaran

    Yes it is very helpful for to reduce time and work

  • john

    thanks Ian it help allot

  • TECHBUZZ

    Thanks a lot..!! great job done!! :)

  • Adrian

    Thanks guys – very helpful. This was really annoying me.

  • Judy

    Thanks for the apostrophe solution – it has been driving me mad. Useful I suppose if you want foreign language letters but I rarely do!

  • Stefan

    It works, 10x!

  • Sarah

    THANK YOU SO MUCH. THIS SOLVED MY ISSUE STRAIGHT AWAY!!! :-) ‘LOVE IT’

  • Kris

    Thanks, that solved the problem!! much appreciated. :)

  • Iain

    Lovely job. This has been driving me crazy!

  • Col

    Thank you very much for your help. I was on the verge of sending my PC back thinking it was a hardware problem

  • Utkarsh Patel

    THE SAME PROB WID TURBO C++ , IM USING WIN 10 , GIVE ME SOME SOLUTION FOR THIS

    • MVatev

      use US QWERTY, not UnatedStates….
      .

  • Nesar Ahmad

    problem solved !!!!

    change the keyboard with – “Australia” keyboard it’s done. :)

  • Sunny

    You are my new hero. I’ve been putting up with this idiotic issue for 6 months!

  • Maddy

    Thanks for this. Very helpful – with Windows 10.

  • Bianca Werner

    I tried for ages to find a fix for this- thank you so much!

  • veeraputhiran

    Good guidance.
    This did work very well for me

  • lu99ke

    WORKED PERFECTLY! MANY THANKS! I WAS GOING TO PULL MY HAIR OUT!

  • Weiss Kreuz

    Thanks, solved my problem. Just remove the United States-International and retain US as your keyboard.

  • Yogi

    Thank you for the article. It helped me with this small irritation!

  • grumpy

    Thanks! Same exact issue on Chromebook!